Monday, June 15, 2015

Lab – Troubleshooting Inter-VLAN Routing



Topology



Addressing Table
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
G0/1.1
192.168.1.1
255.255.255.0
N/A

G0/1.10
192.168.10.1
255.255.255.0
N/A

G0/1.20
192.168.20.1
255.255.255.0
N/A

Lo0
209.165.200.225
255.255.255.224
N/A
S1
VLAN 1
192.168.1.11
255.255.255.0
192.168.1.1
S2
VLAN 1
192.168.1.12
255.255.255.0
192.168.1.1
PC-A
NIC
192.168.10.3
255.255.255.0
192.168.10.1
PC-B
NIC
192.168.20.3
255.255.255.0
192.168.20.1
Switch Port Assignment Specifications
Ports
Assignment
Network
S1 F0/1
802.1Q Trunk
N/A
S2 F0/1
802.1Q Trunk
N/A
S1 F0/5
802.1Q Trunk
N/A
S1 F0/6
VLAN 10 – R&D
192.168.10.0/24
S2 F0/18
VLAN 20 – Engineering
192.168.20.0/24
Objectives
Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot the Inter-VLAN Routing Configuration
Part 3: Verify VLAN Configuration, Port Assignment, and Trunking
Part 4: Test Layer 3 Connectivity
Background / Scenario
The network has been designed and configured to support three VLANs. Inter-VLAN routing is provided by an external router using an 802.1Q trunk, also known as router-on-a-stick. Routing to a remote web server, which is simulated by Lo0, is also provided by R1. However, it is not working as designed, and user complaints have not given much insight into the source of the problems.
In this lab, you must first define what is not working as expected, and then analyze the existing configurations to determine and correct the source of the problems. This lab is complete when you can demonstrate IP connectivity between each of the user VLANs and the external web server network, and between the switch management VLAN and the web server network.
Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.
Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Required Resources
·         1 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
·         2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
·         2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
·         Console cables to configure the Cisco IOS devices via the console ports
·         Ethernet cables as shown in the topology
Part 1:     Build the Network and Load Device Configurations
In Part 1, you will set up the network topology and configure basic settings on the PC hosts, switches, and router.
Step 1:     Cable the network as shown in the topology.
Step 2:     Configure PC hosts.
Refer to the Addressing Table for PC host address information.
Step 3:     Load router and switch configurations.
Load the following configurations into the appropriate router or switch. All devices have the same passwords; the enable password is class, and the line password is cisco.
Router R1 Configuration:
hostname R1
enable secret class
no ip domain lookup
line con 0
 password cisco
 login
 logging synchronous
line vty 0 4
 password cisco
 login
interface loopback0
 ip address 209.165.200.225 255.255.255.224
interface gigabitEthernet0/1
 no ip address
interface gigabitEthernet0/1.1
 encapsulation dot1q 11
 ip address 192.168.1.1 255.255.255.0
interface gigabitEthernet0/1.10
 encapsulation dot1q 10
 ip address 192.168.11.1 255.255.255.0
interface gigabitEthernet0/1.20
 encapsulation dot1q 20
 ip address 192.168.20.1 255.255.255.0
end
Switch S1 Configuration:
hostname S1
enable secret class
no ip domain-lookup
line con 0
 password cisco
 login
 logging synchronous
line vty 0 15
 password cisco
 login
vlan 10
 name R&D
 exit
interface fastethernet0/1
 switchport mode access
interface fastethernet0/5
 switchport mode trunk
interface vlan1
 ip address 192.168.1.11 255.255.255.0
ip default-gateway 192.168.1.1
end
Switch S2 Configuration:
hostname S2
enable secret class
no ip domain-lookup
line con 0
 password cisco
 login
 logging synchronous
line vty 0 15
 password cisco
 login
vlan 20
 name Engineering
 exit
interface fastethernet0/1
 switchport mode trunk
interface fastethernet0/18
 switchport access vlan 10
 switchport mode access
interface vlan1
 ip address 192.168.1.12 255.255.255.0
ip default-gateway 192.168.1.1
end
Step 4:     Save the running configuration to the startup configuration.
Part 2:     Troubleshoot the Inter-VLAN Routing Configuration
In Part 2, you will verify the inter-VLAN routing configuration.
a.     On R1, enter the show ip route command to view the routing table.
Which networks are listed?
____________________________________________________________________________________
Are there any networks missing in the routing table? If so, which networks?
____________________________________________________________________________________
What is one possible reason that a route would be missing from the routing table?
____________________________________________________________________________________
b.    On R1, issue the show ip interface brief command.
Based on the output, are there any interface issues on the router? If so, what commands would resolve the issues?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
c.     On R1, re-issue the show ip route command.
Verify that all networks are available in the routing table. If not, continue to troubleshoot until all networks are present.
Part 3:     Verify VLAN Configuration, Port Assignment, and Trunking
In Part 3, you will verify that the correct VLANs exist on both S1 and S2 and that trunking is configured correctly.
Step 1:     Verify VLAN configuration and port assignments.
a.     On S1, enter the show vlan brief command to view the VLAN database.
Which VLANs are listed? Ignore VLANs 1002 to 1005.
____________________________________________________________________________________
Are there any VLANs numbers or names missing in the output? If so, list them.
____________________________________________________________________________________
Are the access ports assigned to the correct VLANs? If not, list the missing or incorrect assignments.
____________________________________________________________________________________
If required, what commands would resolve the VLAN issues?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
b.    On S1, re-issue the show vlan brief command to verify configuration.
c.     On S2, enter the show vlan brief command to view the VLAN database.
Which VLANs are listed? Ignore VLANs 1002 to 1005.
____________________________________________________________________________________
Are there any VLANs numbers or names missing in the output? If so, list them.
____________________________________________________________________________________
Are the access ports assigned to the correct VLANs? If not, list the missing or incorrect assignments.
____________________________________________________________________________________
If required, what commands would resolve the VLAN issues?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
d.    On S2, re-issue the show vlan brief command to verify any configuration changes.
Step 2:     Verify trunking interfaces.
a.     On S1, enter the show interface trunk command to view the trunking interfaces.
Which ports are in trunking mode?
____________________________________________________________________________________
Are there any ports missing in the output? If so, list them.
____________________________________________________________________________________
If required, what commands would resolve the port trunking issues?
____________________________________________________________________________________
____________________________________________________________________________________
b.    On S1, re-issue the show interface trunk command to verify any configuration changes.
c.     On S2, enter the show interface trunk command to view the trunking interfaces.
Which ports are in trunking mode?
____________________________________________________________________________________
Are there any ports missing in the output? If so, list them.
____________________________________________________________________________________
If required, what commands would resolve the port trunking issues?
____________________________________________________________________________________
____________________________________________________________________________________
Part 4:     Test Layer 3 Connectivity
a.     Now that you have corrected multiple configuration issues, let’s test connectivity.
From PC-A, is it possible to ping the default gateway for VLAN 10? ____
From PC-A, is it possible to ping PC-B? _____
From PC-A, is it possible to ping Lo0? _____
If the answer is no to any of these questions, troubleshoot the configurations and correct the error.
Note: It may be necessary to disable the PC firewall for pings between PCs to be successful.
From PC-A, is it possible to ping S1? _____
From PC-A, is it possible to ping S2? _____
List some of the issues that could still be preventing successful pings to the switches.
____________________________________________________________________________________
____________________________________________________________________________________
b.    One way to help resolve where the error is occurring is to do a tracert from PC-A to S1.
C:\Users\User1> tracert 192.168.1.11
Tracing route to 192.168.1.11 over a maximum of 30 hops
  1    <1 ms    <1 ms    <1 ms  192.168.10.1
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
<output omitted>
This output shows that the request from PC-A is reaching the default gateway on R1 g0/1.10, but the packet stops at the router.
c.     You have already verified the routing table entries for R1, now execute the show run | section interface command to verify VLAN configuration. List any configuration errors.
____________________________________________________________________________________
____________________________________________________________________________________
What commands would resolve any issues found?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
d.    Verify that that pings from PC-A now reach both S1 and S2.
From PC-A, is it possible to ping S1? _____
From PC-A, is it possible to ping S2? _____
Reflection
What are the advantages of viewing the routing table for troubleshooting purposes?
_______________________________________________________________________________________
_______________________________________________________________________________________
Router Interface Summary Table
Router Interface Summary
Router Model
Ethernet Interface #1
Ethernet Interface #2
Serial Interface #1
Serial Interface #2
1800
Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/0/0 (S0/0/0)
Serial 0/0/1 (S0/0/1)
1900
Gigabit Ethernet 0/0 (G0/0)
Gigabit Ethernet 0/1 (G0/1)
Serial 0/0/0 (S0/0/0)
Serial 0/0/1 (S0/0/1)
2801
Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/1/0 (S0/1/0)
Serial 0/1/1 (S0/1/1)
2811
Fast Ethernet 0/0 (F0/0)
Fast Ethernet 0/1 (F0/1)
Serial 0/0/0 (S0/0/0)
Serial 0/0/1 (S0/0/1)
2900
Gigabit Ethernet 0/0 (G0/0)
Gigabit Ethernet 0/1 (G0/1)
Serial 0/0/0 (S0/0/0)
Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

No comments:

Post a Comment